Ransomware Gang Infects Customers Of It Support Firms

At least 126 managed service providers forgot to update a plugin back in 2017 and are now vulnerable to attacks.

Many small IT firms and other types of managed service providers (MSPs) use the two vulnerable applications to centralize data from their clients and manage customer workstations from a remote central location.

Malcare WordPress Security